wiki:PolyorbhicPresentation
close Warning: Can't synchronize with repository "(default)" (Couldn't open Subversion repository /var/repositories/svn/aadl: SubversionException: ("Failed to load module for FS type 'fsfs'", 160033)). Look in the Trac log for more information.

PolyORB HI C

PolyORB-HI-C is our minimal AADL runtime for the C generated code. It is POSIX compliant and run on many operating systems.

Design method

Supported Platforms

  • Native (Linux, Mac OS X, Solaris)
  • RTEMS (tested with the x86 BSP)
  • Nintendo DS (with DSLinux) (see picture of the RMA example running on a Nintendo DS)

Nintendo DS running PolyORB-HI-C

Installation

See the instructions on this page.

Last modified 9 years ago Last modified on 03/09/09 23:32:41

Attachments (2)

Download all attachments as: .zip